API Docs & Tools Blog Help
QuickBooks Online REST API v3 SDK Upgrades Required - Intuit Developer Community Blog

May 19, 2014 | William Lorfing

QuickBooks Online REST API v3 SDK Upgrades Required

As the QBO SDKs continue to grow and mature along with the platform, you will periodically need to update to the latest version of the SDK.
An upgrade is required at this time because earlier versions of the SDK are not compatible with schema changes that have been made in the service.

Who
All developers using QBO SDKs older than the versions below:

Name Version
.NET v3 SDK for QBO 2.0.4
Java v3 SDK for QBO 2.1.2
PHP v3 SDK for QBO 2.0.4


The latest versions can be downloaded below:

Deadline for completion
June 30, 2014

Benefit of completing your migration
Responses will be parsed correctly and the updated SDK will be backwards compatible and your app will continue to work.

Impact of not completing the migration
De-serialization will fail for QBO Journal Entry entities as well as any transaction entity that returns the Line detail TaxInclusiveAmt attribute. Details

Comments

View all
Load more comments